
 
Quick Reference 

 

PowerSchool 8.3 – 05/15/2015 NCDPI Page 1 of 17 

Doc #  – Revision 1 

TIMS to PowerSchool Bus Stop Import 
The Bus Stop Import allows LEAs to upload Student Transportation Data from the 
Transportation Information Management System (TIMS) into the PowerSchool Student 

Transportation Screen. 

LEAs now have the ability to import the following transportation information into 
PowerSchool for Each Bus Rider Assigned in TIMS for both morning and afternoon bus stop 

assignments: 
 

 Bus Number 

 Stop Location or Description 

 Time at Stop 

 

As transportation data changes throughout the year (Bus Numbers, Stop Times, Stop 

Locations, Student Ridership, etc.), there will be a need to update the information in 
PowerSchool. 

 
For Daily/Weekly/Monthly changes in Routing, the Bus Stop Import procedures allow TIMS 

Operators to 
1) PURGE existing bus stop information previously uploaded into PowerSchool 

AND THEN 
2) IMPORT the current student transportation information from TIMS. 

 

The PURGE option in PowerSchool allows LEAs to purge student bus stop information from 
one, several or all schools. 

 

NOTE: LEAs must Purge the Existing Data in PowerSchool before Importing Updated TIMS 

Data. If the Data is Not Purged, then the New Import will Create Duplicated Transportation 

Records for the Student in PowerSchool. 
 

The Bus Stop Import File extracted from TIMS can be filtered to Select Student Data from 

One School, One or More Schools or All Schools.  

Some transportation offices stagger their school bus route updates by School. If a number 

of changes have been completed at one school, the user has the option of purging the 
PowerSchool Data from this one school and then importing the updated TIMS Data from 

that school, leaving all other transportation data in PowerSchool unaffected. Later, when 
another school has updated information in TIMS, the user can purge existing data in 

PowerSchool for that school and import only the new TIMS data from that school. 
The user also has the option to purge from multiple schools, then import only the updated 

data back into PowerSchool.  For other LEAs that have updated TIMS data for all schools, 

the Purge and Bus Stop Import can be completed for all schools. 
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STEP 1: TIMS – Extracting & Formatting TIMS Data for Import 
into PowerSchool 

 
Before you Import TIMS Data into PowerSchool, you will want to be able to trust the 

information you are uploading as Parents, Teachers, Data Managers and Principals, etc. will 
all have access to view your TIMS Route Information. 

 
Prior to Extracting TIMS Data for Import into PowerSchool, please make sure all of the 

following is correct in TIMS. 

 

 Are all Student Assignments updated and accurate? 

 Are Stop Times Accurate for each Assigned Student in TIMS? 

 Are Run and Route Directions Fully Processed? 

 Have you examined your Slack Time for Accuracy and Corrected any Positive or 
Negative Slack Time for Routes with Multiple AM or PM Runs? 

 Are all Arrival and Departure Times To and From School correct? 

 Are all Route IDs and Bus Numbers correct and updated in TIMS? 

 

Once you have verified the accuracy of your data, please Run Rebuild Keys and Dumpall 
(only for Edulog NT Users) before Extracting the PowerSchool Bus Stop Import File from 

TIMS. 

 

A. TIMS Bus Stop Extract Report Filters 

Standard All Students Report Used as Template 

 
1) TIMS Bus Stop Extract for PowerSchool-All Schools 

 District ID is Not Empty, Route ID is Not Empty, School is Not Empty 

o This will compile ridership data for all schools for students who have a 

PowerSchool ID in TIMS and are fully assigned to a TIMS Route. 

o  
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2) TIMS Bus Stop Extract for PowerSchool–Choose School(s) 

 District ID is Not Empty, Route ID is Not Empty, School is within a List (Ask 

Later) 

o This will compile ridership data for one or more schools for students who 

have a PowerSchool ID in TIMS and are fully assigned to a TIMS Route. 

 
 

B. TIMS Bus Stop Extract Output Fields 

 Student District ID 

 Trip Type 

 Stop Description 

 RunMil Time at Stop 

 RteFrq Route ID 

 
 

C. TIMS Bus Stop Extract Output Type 

 ASCII File – User Defined Lengths 

 Text File with Comma Separated Fields 

 

Important:  Currently, the Stop Description Field in PowerSchool Only Accepts 30 

Characters (More Characters Coming Soon, so this is a Temporary Workaround). As 

a result, the Stop Descriptions with 31+ Characters will need to be truncated to 30 

Characters before Exporting the Data Out of TIMS – See Export Specs Below for Each 

TIMS Variable. 

 

 District ID – Length of 12, Starting Position 1 
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 Trip Type – Length of 1, Starting Position 20 

 
 

 Stop Description – Length 30, Starting Position 25 

 
 

 Time at Stop – Length of 11, Starting Position 60 

 
 

 Route ID – Length of 10, Starting Position 75 

 
 

D. TIMS Bus Stop Extract Sort Order 

 District ID 

 Trip Type 
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E. TIMS - Bus Stop Extract Output Path 

The CSV Text File can be exported to any file folder convenient for the User. On the 

ELT Drive where TIMS is Located, Create a Folder named “BusStopExtract” and 
Direct the Output Path to this Folder. 

 

 
The two output files should be named as such: 

 
 QMF_BusStopExtract_AllSchool 

 QMF_BusStopExtract_OneSchool 

Note: When Running the Extract for one or more schools but not the entire LEA, the user 

could modify the Output Name to reflect the School(s) within the file, such as: 
 
 QMF_BusStopExtract_Elem 

 QMF_BusStopExtract_Middle 

 QMF_BusStopExtract_High 

 QMF_BusStopExtract_304_308 

 

F. Editing the Bus Stop Extract in Excel for Import into PowerSchool 

After Generating the Bus Stop Extract, Open an Empty Worksheet in Microsoft Excel. 

Then go to File>Open and browse to the Bus Stop Extract Folder where the file was 

created. (Hint: You may need to switch the file type to “All Files” in order to view the 
Bus Stop Extract in the folder) 

 
 

 
Since the TIMS File is a CSV Text File, Excel will open the Text Import Wizard and 

ask how you want the Data Displayed in Excel. 
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1) Choose Delimited and Select Next 

 

 
 
2) Unselect “Tab” and Choose “Comma” as the Delimiter. The Import Wizard Box 

should then show how the data will be parsed into Columns. 
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3) After choosing Comma as the Delimiter, you can skip “Next“ and Choose “Finish”. 

Your Data should now be parsed into columns and ready for the final edits to be 

completed. 

 

 
 

4) Insert a new Row 1 at top of the spreadsheet. (Hint: Right-Click on Row 1 and 
Choose Insert) 

 
 

5) Now you need to Label Each Colum to Match the Field Names in PowerSchool 

 Column A = Student_Number (must have underscore, no space) 

 Column B = FromTo             (no space or underscore) 

 Column C = Description 

 Column D = DepartureTime           (no space or underscore) 

 Column E = BusNumber  (no space or underscore) 



TIMS to PowerSchool Bus Stop Import 

 

PowerSchool 8.3 – 05/15/2015 NCDPI Page 8 of 17 
Doc #  –Revision 1  

When finished labeling the columns, your spreadsheet should look like this.   

 

 
 
6) PowerSchool will only accept the words “To” or “From” in Column B, so you must 

complete a Search and Replace on the data in Column B. 

 
The data from TIMS in Column B is the Student Trip Type, where 

 1 = “To School” Trip 

 2 = “From School” Trip 

To edit this data, select Column B and then under the Home Tab, Choose Find & 

Select>Replace 
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In the Find and Replace Window, Enter “1” into “Find What” and “To” into “Replace 

With” and Choose “Replace All”. 

 

 
 
Then repeat this step by Entering “2” into “Find What” and “From” into “Replace 

With” and Choose “Replace All”. 

 

 
 

After completing both Find and Replace steps, your spreadsheet should look like this. 
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7) The final step before importing into PowerSchool is to save the edited file as a CSV. 

 

Choose File > Save As and change the “Save Type” to CSV (Comma Delimited). 

 

 
 

When saving the file, you may receive a message saying that some features are not 
compatible with CSV. Do you want to keep the workbook in this format? This is Ok. Please 

Click Yes to Proceed with Saving the File. After saving the edited CSV File, you should now 
have a new Microsoft Excel CSV file inside the BusStopExtract Folder. This will be the file 

that is imported into PowerSchool. 
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Step 2:  Importing TIMS Data into PowerSchool 
 

Note:   TIMS Users will need access to PowerSchool and the Newly Edited file on the same 

Computer/Server to complete these next steps.  You should log in to PowerSchool on the TIMS 

server if possible.  If Internet Access is blocked on your TIMS Server, then you will need to 

transfer the Newly Edited File to your Office Computer to complete the Bus Stop Import. 

 

1) From the Start Page in PowerSchool, choose “Special Functions” from the Menu on 

the Left. 

 
 

2) In the Top Section of the Special Functions Menu, click on the link called “Importing 

and Exporting”. 

 
 



TIMS to PowerSchool Bus Stop Import 

 

PowerSchool 8.3 – 05/15/2015 NCDPI Page 12 of 17 
Doc #  –Revision 1  

3) In the Importing Section, click on the link called “Data Import Manager”. 

 
 

4) On the Data Import Manager Page, you will first need to choose the Source File for 

Import into PowerSchool. Select Browse and Locate the Newly Edited CSV File in the 

Bus Stop Extract Folder. 

 
 

5) Next you will need to choose where in PowerSchool you want to Import this Data. 

a. Under “Import Into”, scroll all the way to the bottom and choose 

“Transportation”. 

b. Then change the “Field Delimiter” to “Comma” and Choose “Next”. 

 

 
 

6) Because you previously entered the correct Field Names in the Spreadsheet, 

PowerSchool sees this and correctly pairs it with the transportation field names. 
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a. If all Variables under “Import File Column” and “PowerSchool Field” are Paired 

Correctly, Click Next to Proceed. If not, the first row of the spreadsheet 

should be edited so that the field names will match. 

 

 

 

7) On the next screen, make sure “Check to Exclude First Row (contains headers)” is 

Checked and then choose the bubble for “Update Existing Record”.  

a. Once both selections are made, Click Import 

 

 
 

8) Depending on the Size of your LEA and the Number of Records you are trying to 

Import, the next step will take varying amounts of time. 

a. At the top it will display the number of processed records (0 of ####) to 

begin with. 

b. You can click the “Refresh” Button in the upper right of the page and the page 

will refresh to show you how many records have been processed and how 

many remain. 

c. For those who may be worried the import is not working, feel free to click 

Refresh along the way. 
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After the system attempts to process all records in the file, you will be notified of how many 

were correctly processed and how many records failed to process. If a record failed to 

process, the system will provide information as to why it failed to import. Failed records 
could occur for several reasons, such as an Incorrect PowerSchool ID not finding a match or 

perhaps the Student is No Longer Enrolled in Your LEA but is still in TIMS. Transportation 
Offices should be regularly performing a student upload as this will help remove any 

students who have transferred out of the LEA. 
 

After the successful import of TIMS Data, you are now able to view Ridership Information on 
the Student Transportation Screen.  

 
 
 

Step 3: Updating Ridership Data in PowerSchool 
 
As LEAs import TIMS Ridership Data into PowerSchool, there will be a need to update this 

information on a regular basis as Student Assignments will change, Stops Times and 
Locations will change, and Bus Numbers may change too as buses are shuffled around to 

different schools or are parked/replaced throughout the year. 
 

In order to update Ridership Data previously loaded into PowerSchool, you must first Purge 
the Existing Data in PowerSchool and Re-Import a new Bus Stop Extract from TIMS. 

The PURGE option allows LEAs to choose  

 

A. One School to Purge Data From 

B. One or More Schools to Purge Data From 

C. Or to Purge Data from ALL SCHOOLS 
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Warning: Do Not Import Another Route Extract from TIMS Without First Purging the 

Transportation Records in PowerSchool. If you Do Not Purge before Importing, the Student 

Transportation Screen will Show Duplicated Transportation Records: The figure below is a 

student record with duplicated Ridership Data caused by not purging data prior to import. 
 

 
 

Note: Transportation data manually edited in this section of the transportation page can NOT be 

uploaded into TIMS.  Any needed changes should be communicated directly to those responsible 

for maintaining bus routes in your LEA. 
 

 
STEP 4: Instructions to Access the Interface to Purge 

Transportation Records 
 

1) From the PowerSchool Start Page, Go to Special Functions from the Menu on Left 

 

 
 

2) From the Special Functions Page, Scroll to the North Carolina Special Functions 

Section at the Bottom of the page and Choose “Transportation Administration”. 
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3) The next page displays the Interface to Purge Transportation Records. 

 
 

From the Purge Transportation Records Interface, you can select to purge records from  
 

A. All Schools (this will highlight the entire list) 

 
 

B. One School (click on the school name to Highlight just one school) 

 
 

C. Multiple Schools (Control-Click to Highlight Multiple Schools) 

 
 

D. There is also an option labeled “Student Status” where you can select to purge 

records for “All Students” or “Only Enrolled Students”. After choosing the School(s) 

from which you want to purge data, leave the Student Status field defaulted to “All 

Students” and Click “Submit”. 
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E. The system will then ask you to confirm the Number of Transportation Records you 

wish to purge. If you believe this number is correct for the School(s) you selected to 

purge from, Click Continue to Proceed with Purging the Previously Uploaded TIMS 

Ridership Data. 

 
 

F. You will then see a message notifying you of how many Transportation Records were 

Successfully Purged. Click Continue to Return to the Transportation Purge Interface. 

 

 

 
G. Once you are finished purging the necessary transportation records, you can return 

to the PowerSchool Start Page and Begin the Process of Importing Your Updated 

Transportation Records from TIMS. 

 

This document is the property of the NC DPI and may not be copied in whole or in part 

without the express written permission of the NCDPI. 


